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Animation's Role in Visualization
Animation brings life to
otherwise inanimate objects
and greatly enhances one's
understanding of
geometry, motion and
transient phenomena.
Pioneered by cartoonists
such as Walt Disney in
the early part of the 20th
century, animation is a
mature artistic technique
that in recent years has
greatly benefited from
computer technology.
While the use of computers
to create animations for entertainment media has become commonplace
through the advent of highly sophisticated software packages, its use in
scientific visualization is far less widespread. CEI has long recognized the
benefits of computer animation for scientists and engineers and has
provided a powerful set of capabilities for the creation and display of
animations in its products. The following article describes these features
and how they have been implemented in our products, which are briefly
described as:
! EnSight -- general-purpose visualization software for science and
engineering
! EnSight Gold -- high-end visualization package for very large data
sets and virtual reality
! EnLiten -- 3D model and animation viewer
! EnVideo -- animation player
! EnVe -- animation editor
EnSight and EnSight Gold are used to visualize data and create
animations. These can be played in EnSight or recorded to a number of
different formats. EnLiten is used to view models as they were rendered
and animated in EnSight. EnVideo is a simple animation player. EnVe is
used to edit multiple animation sequences into one long movie. (In the
following paragraphs, references to EnSight apply also to EnSight Gold,
whose capabilities constitute a superset of those in EnSight.)
The following paragraphs are meant to provide you with an introductory

description of the means to create, edit, play and record animations in
our products. This is not an exhaustive user guide on animation, and it is
recommended that you refer to the extensive descriptions of these
capabilities found in the online manuals for each product.

Types of Animations and their Creation in EnSight
The following different types of animations can be created in EnSight:

!
!
!
!
!
!
!
!
!

Streamline Animation
Plane Sweep Animation
Isosurface Animation
Flipbook Animation
Create Data Animation
Transient Data Animation
Linear Load Animation
Mode Shape Animation
Keyframe Animation

Each of these will be described in detail in the following sections.
Additional information can also be found in the help documentation for
each product.

Streamline Animation
Any particle trace that has been created in EnSight, i.e. steady
streamlines, pathlines from transient flows, massless or massed particles,
or traces computed or measured externally and imported into EnSight,
can be animated using the options found in the quick interaction area for
the streamline feature. Select the particle trace part(s) that are to be
animated from the part list and select Animate from the quick interaction
options. A single pulse will move in the positive time sense from the start
to the end of each trace. As the default color of this pulse is identical to
the color of the trace, you may find it useful to deactivate the visibility of
the trace itself, clicking the visibility icon (eye) found on the left of the
EnSight GUI.
There are many options to affect the appearance of the trace animation.
These are found in the animation option dialog, labeled Animate... in the
quick interaction area. Pulse length, speed, color, thickness, max time,
and frequency can be modified. A sphere can be displayed on the head of
the pulse, the size of which can be constant or scaled according to a
local variable; the head would grow, for example, in areas of high
temperature or velocity magnitude. If a transient solution is animated
using pathlines, it is possible to synchronize the trace animations to a
different type of animation, such as a flipbook animation (see below) of
moving geometry or a changing variable displayed somewhere in the
solution.
The animation options are intuitive and the result of changes will be seen
immediately. The best means to understand these options is to
experiment with a small number of traces, making adjustments to each
option and observing the effects of these changes. Note that while it is
possible to animate traces on a per part basis, animation settings are
global, i.e. they apply to all traces animated.

Plane Sweep Animation
EnSight provides several ways to animate the motion, or sweep, of a
plane through model parts. The plane might actually be one of the
several types of clip planes that can be created in EnSight's Clip feature:
IJK, XYZ, Line, or Plane. (Cylinder, Sphere, Cone, XYZ Box, Revolution
Tool and Revolve 1D Part types of Clips cannot currently be animated in
EnSight). One might be interested in observing how a variable used to
color this plane changes as it sweeps across the model. Another part
could be attached to this clip, such as contours of a variable or vector
arrows, and one could observe these sweeping across the model.
For IJK and XYZ clips, one can quickly sweep in the direction of the
coordinate (I/J/K or X/Y/Z) used to create the initial clip by selecting
Interactive Auto or Interactive Auto Cycle for any such clip parts from
the options in the Quick Interaction area for clips. The parameters Range
Min and Max that appear when using Interactive Auto or Interactive Auto
Cycle limit the extent of the sweeps. The parameter Auto Delta defines
the granularity of the sweep; decreasing this value results in finer and
thus slower sweeps over a range defined by Min/Max.
A second, more general type of plane sweep is available in the create
data type of flipbook animation, described below.

Examples:

IJK plane sweep, Interactive
Auto Cycle

XYZ planesweep, Interactive
Cycle

Isosurface Animation
Similar to plane sweeps described above, isosurfaces can be animated
over a range of Min/Max values. The same options to adjust the Min,
Max and Delta values, found in the Quick Interaction area for
isosurfaces, apply to animated isosurfaces as for animated planes.
A second, more general type of isosurface animation is available in the
create data type of flipbook animation, described below. Note that if a
component of the coordinate vector variable is used as the basis of an
isosurface, a constant XYZ clip results, which itself can be animated as
an isosurface, equivalent to an XYZ clip plane sweep

Flipbook Animation
The term flipbook originated in the simple printed animations popular in
the early part of the 20th century. One flipped through the pages rapidly
to view one or more animated cartoons. EnSight mimics this, loading a
series of images into its flipbook memory to be played back rapidly.
Flipbooks can be either an object type, where the entire geometry is
loaded for each page of the flipbook, or an image type, where only an
image pixel representation of the model is loaded. Object flipbooks
require more memory, but permit one to modify the orientation and
visibility of model parts during the animation. Image flipbooks require
less memory, but the model orientation and appearance cannot be
altered without reloading the flipbook.
Four different types of flipbooks can be loaded and animated:
! Create Data Animation -- create a series of clip planes or isosurfaces
! Transient Animation -- loads a series of time steps or time slices
from a transient model
! Linear Load Animation -- animate model deformation by scaling a
displacement vector
! Mode Shape Animation - animate the cyclical motion of a model's
mode shape
For each of these types of flipbooks described below, a number of
options are provided in EnSight to play the loaded pages automatically or
manually, stepping through the pages in either direction. One can also
modify the speed, direction or extent of the animation by adjusting the
parameters found in the Modify Run parameters. Changes to the model
part representation, other than part visibility and transparency, do not
result automatically in changes to the flipbook. These require a new
flipbook to be reloaded.
For complex scenes and/or large models, a flipbook, especially one of the
object type, can result in a substantial allocation of memory. Therefore it
is advisable to delete a flipbook if it is no longer needed. Lower memory
usage will result if all model parts that are not to be visible in the
flipbook animation are either deleted or their element visual
representation is set to NonVisual prior to loading the flipbook.

Create Data Animation
A create data flipbook does just that: For each page, a new clip plane or
isosurface is created. For clip planes, one first must create a clip plane
using the IJK, XYZ, Line or Plane options. The resulting clip is made
interactive and positioned at the starting location of the desired motion
in the flipbook. Switching now to the flipbook Quick Interaction
parameters, a Create Data load type is selected, Start is selected, and
the Number of Flipbook Pages to Create is set to the desired number of
pages, or total number of clips to create between the start and stop
positions. The plane is now moved to its final position by adjusting the
appropriate parameters or tools, depending on how the plane was
originally created. Stop is then selected for the flipbook, and the two
limits have now been set. Selecting Load generates the intermediate
positions of the clip plane/line. Note that for planes defined using the
plane or line tool, the transformation, or motion of the clip, is
interpolated linearly between the Start and Stop positions. With the
flipbook loaded, the animation can now be played per the instructions in
the previous paragraphs dealing with flipbook animations in general.
A similar approach is followed if an isosurface animation is to be loaded
in the flipbook. Create the first isosurface and set the interactivity to
Manual, select Start and Number of Flipbook Pages to Create in the
flipbook parameters as before, adjust the isosurface to the final value,
then select Stop and Load in the flipbook parameters.
One might wonder why clips and isosurfaces can be animated through
both their respective Quick Interaction parameters as well as by a Create
Data flipbook animation. While isosurfaces and clips can indeed be
quickly animated using the Min/Max/Delta parameters as described
above, the flipbook also provides a means to animate clipped lines
defined using the line tool and clip planes defined using the plane tool,
allowing more arbitrary motion during plane sweeps. The flipbook
animator also permits image flipbook animations (resulting in lower
memory requirements) and a means to record animations, not available
in the clip and isosurface animators.

Transient Data Animation
The most common type of flipbook is a Load Type Transient animation.
One simply creates a desired visual (background, part visibility, coloring,
newly created parts, annotation, plots -- the sum of all graphical entities
as they appear in the graphics window) and loads the flipbook. Control is
provided for the range of time steps or solution time (Adjust Beg/End
Time...) as well as for the step increment or time slice (Increment Time
by) to be taken when loading the flipbook. If particle paths (time
accurate) have already been computed, these can also be animated and
are by default synchronized to the loaded flipbook when it is played.

Examples:

Animation of car part
deformation, ABAQUS

Animation of transient velocity
field, N3S

Linear Load Animation
Static structural analyses result typically in a displacement vector and
one or more scalar, vector or tensor variables representing the state of
the model upon application of a given load. The nature of a static
analysis permits one to scale the load and the resulting displacement
linearly from unloaded to the fully loaded state. A linear load animation
depicts the transition from these two states. Before loading a linear load
flipbook, apply the displacement vector variable to the appropriate model
parts, and color these by an appropriate variable if desired. The flipbook
will scale the displacement vector from zero to the value of the vector,
and vary the color from its lowest level to the color palette chosen for
the variable by which the parts are colored.

Examples:

Linear load animation of ANSYS
cantilever beam

Mode Shape Animation
Structural analysis software can be used to predict the vibrational modes
for an excited structure, also referred to as an Eigenvalue or mode shape
solution. Such computations result in a displacement vector for each
vibrational mode, or input load frequency. By animating the motion of a
model from the positive to the negative extremes of this displacement, it
is possible to gain an understanding of the relative importance of each
vibrational mode. Before loading a mode shape flipbook, apply the
displacement vector variable to the appropriate model parts. The flipbook
will automatically scale the displacement vector from its negative to its
positive extreme.

Keyframe Animation
Keyframe animations depict model details and results. By saving a series
of key frames, or model positions, then interpolating between these
positions, it is possible to create smooth fly-arounds, fly-throughs or
even part explosions for a given model. One begins by choosing the
initial desired position of the model and saving this position, or
keyframe, by selecting the save button in the Quick Interaction area for
keyframe animations. The model is then moved to the next desired
position, a new keyframe is saved, and so forth. When the keyframe is
run, the model will move smoothly from one keyframe to the next.
Selecting the option Animate Transparency Change will include changes
in part transparency between keyframes, allowing parts to fade in or out
during playback of the animation. Selecting the option Use Interactive
Iso/Clip will record the value of an interactive isosurface or the position
of an interactive clip (IJK, XYZ, Plane, Line type of clips) along with the
model part position at each keyframe. Saving a series of different clip
positions at each keyframe allows complex motions of plane sweeps,
such as along the axis of a manifold or any other curved model part.
The parameters found in the Set Speed/Actions... dialog allow one to
vary the speed of motion between any two keyframes; by default, 20
subframes are created between any two keyframes. Increasing the
number of sub-frames between keyframe pairs results in slower motion
between them. (A rule-of-thumb in creating any animation is that 30
frames equal approximately one second of animation.) The Set
Speed/Actions... dialog also contains an option to execute a series of
commands at the start of a new keyframe. This can be used to vary
annotation and part visibility, for example, or to turn other types of
animations on or off. The Hold option in this dialog can be used to hold
the animation at a given keyframe for a given number of frames prior to
progressing to the next frame. Holds are useful to permit the viewer to
understand what he/she is looking at before motion begins.
The Keyframe Animator senses changes made in EnSight's Frame Mode.
By attaching certain parts to new local frames, one can move these
parts relative to one another during a keyframe animation, resulting in
so-called part explosions. These can be very useful to initially depict the
entire model, then remove exterior parts to reveal inner details.
Keyframe animations can become quite lengthy and are typically created
only to be saved to one of the digital video formats supported by
EnSight (see "Playing and Recording Animations in EnSight"). While
creating keyframe animations, you will typically want to play and modify
these in EnSight several times prior to saving. Since a fully rendered
model can result in lengthy playback times on even the fastest
computers, it is recommended to create the keyframe animation with
only the most essential parts visible, and these should be rendered in
the feature angle form of element visual representation. This will result in
much faster playback speeds. Once you are satisfied with the animation,
render the model as you wish to see it in the final form, make the

selections to record to a file, and run the animation.
The creation of a good, professional-quality keyframe animation requires
some practice and the observance of proven techniques. A description of
these is too lengthy for the purpose of this article and will be addressed
in further articles from CEI.

Examples:

Zoom up with transparency
changes

Part Explosion

Combining Two or more Types of Animations
All of the various forms of animations described in this article can be
viewed and recorded in EnSight simultaneously. A typical example would
be to first create a flipbook animation of a transient phenomena, such as
a vehicle impact simulation, and combine this with a keyframe animation
showing the vehicle motion and deformation from various viewpoints.
The examples below show how two or more types of animations can be
combined in EnSight.

Examples:

Vehicle impact flipbook and
keyframe animation - 869 KB

Particle trace and plane sweep
animation - .99 MB

CAD model fade-out to reveal

Playing and Recording Animations in EnSight
A brief description on how one plays the various types of animation has
been provided above. In all instances, controls are provided to vary the
speed of playback. For animated streamlines, playback controls are found
in the Animate... dialog for streamlines. For clip plane and isosurface
animation, one varies the playback speed by changing the Auto Delta
parameter that determines how fine or coarse EnSight creates the
clips/isosurfaces between the defined Range Min/Max extremes.
For all four types of flipbook animations, options to control playback
speed and direction are found in the Modify Run... dialog in the Quick
Interaction area for flipbook animations. As described earlier, the speed
of keyframe animation playback is determined by the number of
subframes between keyframe pairs. Note that in all instances, the actual
speed of playback cannot be explicitly specified by the user, but instead
is a function of model size and other aspects of the animation as well as
the performance of the computer.
Animations can be recorded to files only from within the flipbook
animation and keyframe animation Quick Interaction areas. Once you are
satisfied with the animations when run from within EnSight, they can be
saved out either one frame at a time to any of EnSight's supported
image formats, or the entire animation can be saved to a single video
format file. In either case, choose first the Record... button to select the
desired format (Set Format...) and enter the desired file name prefix.
Next, define the size of the image file(s) using the Record... (Save
Window Type) option for flipbooks or the Viewing Window... options for
keyframe animations. The actual recording of a flipbook animation takes
place when the Record button is selected. The actual recording of a
keyframe animation takes place when the Run button is selected.
Three different video formats are available in EnSight: uncompressed
AVI, MPEG and EVO. For the best compromise between animation quality
and file size, CEI recommends use of the EVO format, which can be
viewed in CEI's free .evo viewer, EnVideo. See more about EnVideo
below.
EVO files use either JPEG or RLE (run length encoding) compression.
Whereas JPEG compression generally results in smaller files, RLE
compressed animation files will exhibit better image quality. Currently,
EVO files can be played only in CEI's EnVideo player (see below). EVO
files are generally larger than compressed AVI and MPEG files, but have
superior image quality. They can be played on any hardware platform for
which a version of EnVideo exists.
AVI files created in EnSight are uncompressed, resulting in large file
sizes. These can be compressed, however, to a small fraction of their
original size (typically under 10%) using the program avi_compress,
which is found in the unsupported directory of every EnSight installation.
Note: avi_compress will execute only on a PC under the Windows
operating system. See the README file in this same directory for details.
MPEG files created in EnSight are compressed according to default
parameters chosen to result in a balance between file size and image
quality. These parameters can be modified by editing the file
tmp_mpeg.param found in your .ensight7 configuration directory, which
is automatically created by EnSight in your home directory upon your
initial use of EnSight.
The following table compares file sizes for several animations saved at a
window size of 320 x 240 in EnSight to three different formats:

Animation

EVO
(JPEG)

EVO
(RLE)

Flipbook
CFD

9,622KB

Flipbook
CAD

6,381KB

AVI
(uncom.)

AVI
(comp.)

MPEG

17,216KB 54,005KB

3,859KB

1,016KB

15,303KB 36,604KB

2,026KB

689KB

Keyframe
CSM

3,506KB

4,748KB

46,204KB

1,720KB

870KB

Playing Animations in EnVideo
EnVideo is an animation player developed by CEI to play .evo format
video animations. It is a simple but powerful program, requiring no
training and little documentation. Versions of EnVideo are available free
of charge from CEI's web site for any hardware platform for which
EnSight is also available. At the time of this writing, EnVideo accepts
only .evo format files. EnSight, EnSight Gold and EnLiten (see below)
can all generate such files. An API is also available free of charge from
CEI's web site for the purpose of generating .evo format files in any
application.
Buttons to control animation direction, speed, frame stepping, graphics
window size, and to toggle to stereo mode are provided in EnVideo.
(Note that in order to display an .evo animation in stereo, it must have
been recorded in stereo to begin with.) You can append .evo files,
resulting in a longer animation made up of two or more individual .evo
files. Appending can be selected in the command line options or through
the File > Append Movie... option.
By default, EnVideo streams images from disc to the graphics window.
For small-sized animations, this results in fast playback on most
systems. For animations meant to be shown on large displays, such as
projected screen systems requiring a saved window size of greater than
640 x 480, the .evo file size can become large and the playback speed
might be too slow. For these situations, EnVideo provides an option to
first cache the animation to memory prior to playing. The resulting
playback speed is much greater, but EnVideo could require a very large
cache memory. Should you wish to take advantage of the caching
capability, start EnVideo with the "-cache" command line option. The size
of the required cache memory is (image pixel width) x (image pixel
height) x (3 bytes) x (number of frames in the animation). For stereo
animations, the memory requirement will be double this figure. (Note
that the cache option is not currently available for the Windows version
of EnVideo)
Any frame of an animation in EnVideo may be printed using File >
Print...

Viewing Models and Animations in EnLiten
Whereas EnVideo provides an excellent means to play animations created
in EnSight and EnSight Gold (or EnLiten, see below), EnLiten provides
the user with full control over the original 3D model, including
animations. EnLiten is a simple but powerful program, requiring no
training and little documentation. Inspired by the defunct VRML 3D
geometry standard (EnSight and EnSight Gold still support an option to
export VRML-2 format files), EnLiten relies on .els scenario files created
in EnSight. File > Save > Scenario..., a scenario file with the default file
type of .els, contains the geometry of all model parts selected in the
EnSight parts list at the time of saving the file. If keyframe, flipbook or
particle trace animations have been created in EnSight, the user can
select which of these will also be saved into the scenario file. One can
also save certain model views and notes into the scenario file. For more
information on saving scenario files, see How To Save Scenario in the
EnSight online How To Manual (Help > How To Manual...)
Once the .els file exists, it can be loaded into EnLiten either by entering
it in the command line during execution, or by starting EnLiten by
entering the file name in File > Open EnLiten scenario... The model can
be rotated/translated/zoomed in the graphics window, and any saved
animations can be played. Options exist in EnLiten to display the model
in full screen or stereo mode. Views saved into the scenario file can be
selected. Notes saved in the scenario file can be reviewed and appended
in the Scenario Note Viewer/Composer. A particular view of the model
can be saved to any one of a number of image formats using File >
Save Image... Animations playing in EnLiten can be saved to EVO, AVI
or MPEG files using File > Save Animation...
EnLiten Gold, which can be purchased from CEI, includes all of EnLiten's
features as well as EnSight Gold's advanced rendering capabilities for
virtual reality environments. Contact CEI or one of its authorized
distributors for pricing information.

Editing Animations in EnVe

EnVe is a simple, command-driven program to edit animations saved in
CEI's EVO format. It can be used to paste together multiple animation
segments into a complete movie, processing commands interactively or
from command files.
Currently, EnVe performs the following operations:
! specify an output movie
! append a movie or a subset of a movie
! copy the last frame
! query a movie file

The Future of Animation at CEI
Animation remains one of the most effective means to display complex
geometry and physical phenomena resulting from numerical simulations.
CEI's products provide a complete suite of tools to create, play, record
and view animations of many different types. Current animation
development work at CEI focuses on the following:
! improvements to EnSight's keyframe animator
! reduction of EnLiten scenario file size
! addition of EnSight-like controls to EnVideo and EnLiten
These improvements will be incorporated into future releases of our
products.
For further details regarding the animation capabilities of CEI's products,
please refer to the online How To Manual and User Manual.

